App Slowness
Incident Report for Truly
Postmortem
Posted Nov 27, 2023 - 17:13 EST

Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 14:19 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2023 - 14:19 EST
Monitoring
Application performance is back to normal.
Posted Nov 21, 2023 - 13:48 EST
Identified
We are seeing application performance recover. Another update to follow shortly.
Posted Nov 21, 2023 - 13:42 EST
Investigating
We have received mentions of users being unable to load the application. We are investigating.
Posted Nov 21, 2023 - 13:32 EST
This incident affected: Desktop App.