Outbound Call Failure Reports
Incident Report for Truly
Postmortem
Posted Nov 21, 2023 - 14:20 EST

Resolved
No further reports have emerged regarding this incident, so we are closing the issue. A detailed post-mortem will follow.
Posted Nov 17, 2023 - 16:25 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2023 - 12:19 EST
Monitoring
The issue has been remediated and we are monitoring the situation. More updates to follow.
Posted Nov 17, 2023 - 12:12 EST
Identified
Our engineers have identifeid the problem and are working to remediate it.
Posted Nov 17, 2023 - 10:29 EST
Update
Our engineers are continuing to investigate this incident.

User are recommended to use our mobile applications while this continues.
Posted Nov 17, 2023 - 09:24 EST
Update
We have confirmed the issue is limited purely to our computer based calling experience. The team is continuing to investigate.
Posted Nov 17, 2023 - 09:10 EST
Investigating
We are investigating reports of difficulty initiating outbound calls
Posted Nov 17, 2023 - 09:07 EST
This incident affected: Outbound Calls.